Back to top

Добавление групп и элементов в справочник.

Опубликовано e-1c@mail.ru - пт, 08/12/2016 - 14:12

  Спр = Справочники["Контрагенты"];
  ИмяГр = "Группа";
 
  НайденнаяСсылка = Спр.НайтиПоНаименованию(ИмяГр, Истина);
 
  Если Не НайденнаяСсылка = Спр.ПустаяСсылка() Тогда
  Если Не НайденнаяСсылка.ЭтоГруппа Тогда
  Предупреждение("ВНИМАНИЕ! Найден элемент справочника с указанным наименованием!"+
   Символы.ПС+"Группа с таким же наименованием создана не будет!"); 
  Возврат; // Здесь сволочь ругается - хотя все правильно!
  КонецЕсли;
  КонецЕсли;
 
  Родитель = НайденнаяСсылка;
  Если НайденнаяСсылка = Спр.ПустаяСсылка() Тогда //Если не находим группу по наименованию
  НоваяГруппа = Спр.СоздатьГруппу(); 
  НоваяГруппа.Наименование = ИмяГр;
  НоваяГруппа.Записать();
  Родитель = НоваяГруппа.Ссылка;
  КонецЕсли;
 
 
  // Добавляем новый элемент справочника!!!
  НовыйЭлемент = Спр.СоздатьЭлемент(); 
  НовыйЭлемент.Наименование = "Новый элемент"; 
  НовыйЭлемент.Родитель = Родитель;
  НовыйЭлемент.Записать();