Back to top

Отключение интернет-поддержки.

Опубликовано e-1c@mail.ru - ср, 08/24/2016 - 06:03

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ПользователиБазы = ПользователиИнформационнойБазы.ПолучитьПользователей();
	Если ПользователиБазы.Количество()>0 тогда
	   Для Каждого Пользователь Из ПользователиБазы Цикл
	      ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь, , Пользователь.Имя);
		  ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь , Пользователь.Имя);
	      Сообщить("Для пользователя " + Пользователь.Имя + " интернет-поддержка отключена");
	  КонецЦикла;
  Иначе
	  ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ПовторитьПопыткуПодключенияПриСтартеПрограммы", Ложь);
	  ХранилищеОбщихНастроек.Сохранить("ИнтернетПоддержкаПользователей", "ВсегдаПоказыватьПриСтартеПрограммы", Ложь);
      Сообщить("Интернет-поддержка отключена");
	КонецЕсли;
КонецПроцедуры