Back to top

Добавление Договора

Опубликовано e-1c@mail.ru - ср, 08/24/2016 - 04:52

// Если Объект.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ПустаяСсылка() Тогда
//	Объект.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо;
//КонецЕсли;
 
Контрагент = Объект;
Контрагент.Записать();
Если НЕ Контрагент.Ссылка = Справочники.Контрагенты.ПустаяСсылка() Тогда
	Если НЕ Контрагент.ЭтоГруппа = Истина Тогда
	Если НЕ ЗначениеЗаполнено(Контрагент.ОсновнойДоговорКонтрагента) Тогда
		НовДоговор = Справочники.ДоговорыКонтрагентов.СоздатьЭлемент();
		//НовДоговор.Организация		   = Справочники.Организации.НайтиПоКоду("000000002"); // Основная организация
		НовДоговор.Организация		   = Справочники.Организации.НайтиПоНаименованию("ООО"); // Основная организация
		НовДоговор.ВалютаВзаиморасчетов  = Справочники.Валюты.НайтиПоКоду("643"); // рубли
		//НовДоговор.ВедениеВзаиморасчетов = Перечисления.ВедениеВзаиморасчетовПоДоговорам.ПоДоговоруВЦелом;
		Если  Контрагент.Родитель.Наименование = "Поставщики" Тогда
		НовДоговор.ВидДоговора		   = Перечисления.ВидыДоговоровКонтрагентов.СПоставщиком;
		Иначе
		НовДоговор.ВидДоговора		   = Перечисления.ВидыДоговоровКонтрагентов.СПокупателем;
		КонецЕсли;
 
		НовДоговор.Владелец			  = Контрагент.Ссылка;
		НовДоговор.Наименование		  = "Основной договор";
		//НовДоговор.УстановитьНовыйКод(); // в скобках префикс см. синтаксис помощник
	    Сообщить(" "+Контрагент.Код + "  "+Контрагент.Наименование);
		Попытка
		НовДоговор.записать();
		НовыйОсновнойДоговорУказан = Истина;
		Контрагент.ОсновнойДоговорКонтрагента = НовДоговор.Ссылка;
		//Контрагент.Записать();	
		Исключение
		Сообщить(ОписаниеОшибки(),СтатусСообщения.Важное);
		НовыйОсновнойДоговорУказан = Ложь;
		КонецПопытки;
	КонецЕсли; 	
	КонецЕсли; 	
КонецЕсли;
//ЭтаФорма.Обновить();