Back to top

Встроенный язык

Механизм управляемых блокировок

Опубликовано e-1c@mail.ru - вт, 05/16/2017 - 08:43

Система “1С:Предприятие” позволяет использовать два режима работы с базой данных: режим автоматических блокировок в транзакции и режим управляемых блокировок в транзакции.

Типы 1С

Опубликовано e-1c@mail.ru - вс, 05/14/2017 - 16:53

Так как в программном коде мы работаем со значениями, то периодически требуется знать их тип. Тип 1С всегда указывается в метаданных у реквизитов — в справочниках, документах.

Работа с типами 1С часто используется:

Использование рекурсивных вычислений

Опубликовано e-1c@mail.ru - сб, 05/13/2017 - 18:41

Из курса программирования известно, что рекурсией называется вызов функцией самой себя. Фактически, рекурсия является первым шагом к логическому программированию, потому что грамотное ее использование позволяет составить алгоритм, не решая задачи окончательно.

Особенности редактирования значений произвольного типа в табличном поле

Опубликовано e-1c@mail.ru - вт, 05/09/2017 - 16:18

В некоторых случаях требуется организовать ввод данных произвольного типа в колонки табличного поля. Причем тип данных, которые будут вводиться в колонку табличного поля, заранее неизвестен. Например, пусть необходимо создать форму подбора, позволяющую выбирать значения произвольного типа. Причем тип выбираемого значения заранее неизвестен и выбирается из заранее сформированного списка доступных типов. Выбранные значения необходимо поместить в таблицу значений.

Математические вычисления в 1С

Опубликовано e-1c@mail.ru - ср, 04/26/2017 - 11:34

Извлечение корня

Функция Корень(Основание,Степень)
     Если Степень = 1 Тогда
          Возврат(Основание);
     КонецЕсли;
     Факториал = 1; Степень_ = 1; Сум = 0;
     СтепеньЕ = 1/Степень*Лог(Основание);
     Для ии = 1 по 28 Цикл
          Факториал = Факториал * ии;
          Степень_ = Степень_ * СтепеньЕ;
          Сум = Сум + Степень_/Факториал
     КонецЦикла;
     Возврат(1+Сум);
КонецФункции
//******************************************************************
// КвaдpaтныйКopeнь(Apгумeнт)
//
// Пapaмeтpы:
// Apгумeнт - нeoтpицaтeльнoe чиcлo
//

Описание типов и квалификаторы.

Опубликовано e-1c@mail.ru - вт, 04/25/2017 - 17:13

Описание типов это объект, который управляет ограничением допустимых типов значений, присваиваемых объектам системы. Этот объект используют в момент создания объектов, он определяет набор допустимых типов и используется как свойства создаваемых объектов.

Тип значения - получить полное имя ссылочного типа.

Опубликовано e-1c@mail.ru - вт, 04/25/2017 - 12:51

Что бы узнать к чему относится переменная или реквизит какого либо объекта метаданных (ссылочного типа), можно воспользоваться командой _Тип = ТипЗнч(_переменная);

В результате её выполнения мы получим <Синоним> той ссылки которой является данная переменная.

Однако синоним в большинстве случаев не совпадает с наименованием объекта метаданных, кроме того не очевидно чем именно является данный объект, справочником, перечислением, документом или еще чем.

Получение ссылки не записанного объекта 1С

Опубликовано e-1c@mail.ru - вт, 04/04/2017 - 12:19

Иногда необходимо получать ссылку нового объекта(например элемента справочника или документа) еще до того как он будет записан. Если попробовать получить его ссылку, через .Ссылка то в результате возвращена она будет пустой, так как ссылка для этого объекта еще не создана.

В такой ситуации нужно создать ссылку нового объекта самостоятельно. Для примера рассмотрим ситуацию когда необходимо получить ссылку нового(еще не записанного) документа Реализация товаров и услуг. Пусть НоваяРеализация - объект нового документа.

Для начала создадим новую ссылку на документ

Получение уникального идентификатора из ссылки и получение ссылки по уникальному идентификатору

Опубликовано e-1c@mail.ru - вт, 04/04/2017 - 09:35

В любой конфигурации 1С 8 у каждого объекта(документа, элемента справочника, элемента плана видов характеристик и т.п.) есть уникальный идентификатор(УИН). При помощи него можно переносить объекты между базами РИБ не боясь задвоения данных, быстро находить элемент справочника или документ и т.п.

Как получить уникальный идентификатор из ссылки? При помощи свойства ссылки УникальныйИдентификатор().
Пример 1: